Crédits à zéro

[Traité]

  • 0
Bonjour.

Cela fait plusieurs fois que mes crédits sont indiqués à zéro (et que je ne peux donc pas les utiliser) alors que j'en ai en stock. Je suis donc obligé d'en acheter de nouveaux pour acheter quelque chose, après cela j'ai bien l'indication de mon stock total réel, puis à la connexion suivante rebelote. C'est bien pénible.
Merci de m'aider rapidement.

http://compagniedesolitude.guilde-teso.fr/fr/accueil
  • 0
Salut,

As-tu fait des suppression dans le site sur les éléments donnant des crédits gratuits :
Utilisateurs, Sujets du forum (ou catégories contenant des sujets), Evènements, Personnages ou Recrutements ?
----- -----
Pour les rapports de bugs, merci de lire le sujet suivant : Comment effectuer un rapport de bug
Bugs/Demande d'aide : Indiquez dans votre message ou votre profil votre site de guilde !

  • 0
Bonjour.

Désolé pour le délai, mode vacances.

J'ai supprimé de façon régulière et modérée quelques utilisateurs et personnages, mais comme je le fais depuis 3 ans et au même rythme sans que cela n'ai jamais eu d'incidence à ce niveau.

Ce matin mes crédits indiqués étaient donc encore une fois à zéro.
J'achète 200 crédits. Le solde indiqué passe à 200.
Je dépense 75 crédits (espace disque +250 MO).
Le site devrait alors m'indiquer 125 crédits en stock mais il "retrouve" alors mes crédits et m'indique 573.

Le problème est que cela fait plusieurs fois que plusieurs jours après le stock revient étrangement à zéro.

Pour rebondir sur ton hypothèse :
- Il m'est arrivé ponctuellement (il y a longtemps) de faire des grosses suppressions sans que cela n'impacte jamais mon stock de crédits, qui pourtant était modeste à l'époque.
- Le problème m'arrive aujourd'hui alors que les suppressions sont modérées et que mon stock récent de crédits était élevé depuis un certain temps (+1000).
Donc d'un point de vue technique et historique cela ne me semble pas venir de cette raison.
  • 0
Salut,

Après vérification, cela vient bien des crédits gratuits : il y avait une différence entre le script de calcul journalier (correct) et celui effectué après l'achat et l'utilisation de crédits (incorrect).
Le second ne prenait pas en compte les suppression sur les comptes utilisateurs et cela était rectifié par le script exécuté chaque jour.
Tu obtenais donc 886 crédits au lieu de 70.



En reprenant l'historique de tous les achats effectué, les crédits gagnés gratuitement et les dépenses, la guilde est en réalité à -243 (donc plus de dépenses que de crédits).
J'ai rajouté des crédits pour que le compte de la guilde revienne à 0.
----- -----
Pour les rapports de bugs, merci de lire le sujet suivant : Comment effectuer un rapport de bug
Bugs/Demande d'aide : Indiquez dans votre message ou votre profil votre site de guilde !

  • 0
Hello.

Ok cela semble plus clair, j'aurais dû commencer par prêter meilleure attention à l'historique.

Merci à toi.

Lien vers le message

Utilisez les codes suivant pour partager le message sur un forum ou un site.