Soucis avec le menu

[Traité]

  • 0
Bonjour,


Alors voilà, j'ai voulu faire un tri dans le menu de mon site... et là.. gros soucis ^^"

Explications :
J'ai voulu supprimer quelques pages que je ne voulais pas garder, en prenant le soin de supprimer les sous-pages en premier. Puis pour certaines d'entre elles, je remarque qu'elles sont toujours dotées d'un sous-menu : or aucune page n'y figue dans ces sous-menu que ce soit à l'affichage sur le site, que via le bouton affichant la hiérarchie des pages (il y avait le '+' d'affiché mais aucune page n'apparut lorsque j'ai cliqué dessus). 
(J'aurais bien pris des screens, mais là je ne peux plus. J'ai fais une grosse bourde par la suite xD   )

Je me suis donc retrouvée avec des pages insupprimables (une page contenant des sous-pages (même des sous-pages fantômes) ne peut pas être supprimée).
J'ai restauré les pages précédemment supprimées, puis j'ai eu l'idée d'utiliser les droits de visibilité. J'ai donc caché les pages que je ne souhaitais pas faire apparaitre dans mon menu. Je venais de résoudre mon petit soucis mais venais d'en créer un autre...

J'ai renommé et fait disparaître la page index du site, en la prenant pour ma page du même nom : 'accueil', qui possédait un sous-menu sans pages. Je l'avais créé afin qu'elle se retrouve sur la barre de navigation et face référence à la page d'accueil principale.
(Je ne sais pas si je me suis bien exprimée, dites moi si ce n'est pas bien clair).

Une fois qu'on a enlevé toutes visibilités de ces pages, même l'administrateur ne peut les voir dans le plan du site, du moins, il me semble. Je ne les ai retrouvé nul part. Je ne peux donc pas leur rendre leur visibilité ou simplement les éditer.
De plus, après avoir modifié les droits de visibilité de la page d'accueil principale, il m'est impossible d'avoir de nouveau accès au plan du site.

Enfin voilà... soit j'ai fais une mauvaise utilisation, soit je suis tombée dans un bug, soit les deux...


Mon site :
http://arfost.guildi.com/fr/accueil
Le 'accueil' de l'adresse fait référence à ma page créée que je voulais supprimer, et non à la page index.
Car si on utilise l'adresse http://arfost.guildi.com, vous pourrez voir qu'elle mène à celle que j'ai renommé et faite disparaître : ce qui donne une belle page blanche.
D'ailleurs, sur le menu du site, on peut toujours voir la page 'accueil' avec son sous-menu fantôme. Il y a le petit icône indiquant le sous-menu, mais aucune page ne s'y trouve.


Serait-il possible de me réinitialiser la barre de navigation s'il vous plait ?



Ps : désolé pour les fautes d'orthographes/grammaires..
  • 0
Salut,

Il y a en effets quelques soucis, la page d'accueil ne devrait pas pouvoir être supprimée et il ne devrait pas y avoir de pages ayant la même URL (oubli d'une vérification côté serveur).
Je regarde ce problème dès demain matin et je mettrais à jour ton menu et tes pages.
----- -----
Pour les rapports de bugs, merci de lire le sujet suivant : Comment effectuer un rapport de bug
Bugs/Demande d'aide : Indiquez dans votre message ou votre profil votre site de guilde !

  • 0
Salut,

J'ai corrigé les problèmes du menu. Toutes les pages sont au même niveau, je te laisse les déplacer pour l'organiser comme tu le souhaites

Pour le problème d'accès au site, cela vient de la page d'accueil pour laquelle les droits d'accès visiteurs/membres avait été enlevés, ce qui fait qu'un utilisateur arrivant sur le site n'avait pas les droits d'accès et était donc redirigé.... vers l'accueil (et le navigateur détectant une redirection en boucle stoppe l'accès).

Il reste également quelques problème au niveau des pages : le calcul de leur position semble erroné lors d'une opération (création, édition, déplacement de page....). Je l'avais déjà constaté auparavant mais je n'arrive pas à reproduire l'erreur.

Je vais essayer de corriger rapidement tous ces problèmes sur la plateforme.
N'hésites pas si tu rencontres d'autres soucis
----- -----
Pour les rapports de bugs, merci de lire le sujet suivant : Comment effectuer un rapport de bug
Bugs/Demande d'aide : Indiquez dans votre message ou votre profil votre site de guilde !

  • 0
Bonjour,

Super, merci beaucoup 

Lien vers le message

Utilisez les codes suivant pour partager le message sur un forum ou un site.